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Common Questions

Why does my screen change size when Thinkin  ’   Science is     run?  
Why does Thinkin  ’   Science     automatically start when the CD is placed in the drive?  

How can I run Thinkin  ’   Science     without the CD in the drive?   
How do I uninstall Thinkin  ’   Science?  

Adjusting Edmark AutoResize
Adjusting Edmark AutoPlay

Troubleshooting

Troubleshooting System Lockups, and Erratic Program Behavior

Error messages

"Changing video mode not supported"
"Resource Manager Error"
   “  Illegal Operation  ”  
   “  Invalid Page Fault  ”  

Fine-Tuning Your System

Improving performance by removing background applications
Improving performance by installing the latest hardware drivers



Why does my screen change size when Thinkin’ Science is run?

Thinkin’ Science may automatically adjust the size of the display so that only Thinkin’ Science is visible. 
In some cases, icons are moved around on the desktop. The “Edmark Registry Utility” can be used to 
disable this feature. Click below for further instructions.

Using the Edmark Registry Utility 



Why does Thinkin’ Science automatically start when the CD is placed in the
drive?

Thinkin’ Science may launch automatically when placed in your CD-ROM drive. You can temporarily 
disable this feature by holding down the Shift key while inserting the CD-ROM. You can also turn this 
feature on or off for all Edmark products using the “Edmark Registry Utility.” Click below for further 
instructions.

Using the Edmark Registry Utility 



Using the Edmark Registry Utility

The Edmark Registry Utility can be used to enable (turn on) or disable (turn off) the following features for 
most Edmark Windows products. 

· Enable or disable AutoPlay. If AutoPlay is enabled, the Edmark CD-ROM will run automatically 
when placed in your CD-ROM drive.

· Enable or disable automatic resizing of your display by Edmark Windows products.

To use the Edmark Registry Utility, perform the following steps: 
1. Place the Thinkin’ Science CD-ROM in your CD-ROM drive. Hold down the Shift key while 

inserting the CD-ROM to prevent it from starting automatically.
2. Click Start | Run. 
3. Type: D:\EDINST\UTILITY\EDMKREG and press Enter.

(where “D” represents the letter of your CD-ROM drive).
4. Select the box to the left of the option(s) that you want to change. A check in the box disables the 

option.
5. Once you have made the desired changes, click OK.



How can I run Thinkin’ Science without the CD in the drive?

Thinkin’ Science can be copied to the hard drive so that the CD-ROM is no longer required for use of the 
program. This procedure requires that you have at least 132MB of free hard drive space.

To copy Thinkin’ Science onto the hard drive, follow these steps: 
1. Install the application as detailed in the Thinkin’ Science User's Guide. Once installation is 

complete, leave the CD-ROM in the drive and proceed with the following instructions.
2. Double-click the My Computer icon on the Desktop.
3. Click the CD-ROM drive icon, highlighting it. (This is usually the D or E drive.)
4. Click the File pull-down menu and select Open.
5. Double-click the SCOUTS folder icon.
6. Click the Edit pull-down menu and select Select All.
7. Click the Edit pull-down menu and select Copy.
8. Double-click the My Computer icon on your Desktop (again).
9. Click the C: drive icon, highlighting it.
10. Click the File pull-down menu and select Properties.
11. Check the amount of free space on this drive. If it is more than 132MB, then you have sufficient 

hard drive space to copy the program. If the amount is less than 132MB, then you do not have 
enough hard drive space to copy the program to your hard drive and should not continue this 
procedure.

12. Click OK.
13. Double-click the C: drive icon.
14. Double-click the Program Files folder icon.
15. Double-click the Edmark folder icon.
16. Double-click the folder titled Thinkin’ Science.
17. Click the Edit pull-down menu and select Paste. The files from the CD will now be copied to your 

hard drive. If you are prompted to overwrite or replace any files, answer Yes to All. 

NOTE: Due to the large amount of data being transferred, this process may take several minutes.
Once the process is complete, the copying window will disappear. Wait until this window 
disappears before proceeding to step 18. 

18. Click the Edit pull-down menu and select Select All. 
19. Click the File pull-down menu and select Properties.
20. Click the box next to "Read-only" so that it does not contain a check-mark.
21. Click OK.
22. Click the File pull-down menu and select Close for all windows that were opened during this 

process. 

Remove the Thinkin’ Science CD-ROM from your drive and run the application. You will not be prompted 
to insert the CD-ROM to run the program. 



How do I uninstall Thinkin’ Science?

To remove Thinkin’ Science from your system, perform the following steps: 
1. Click Start | Settings  Control Panel. 
2. Double-click Add/Remove Programs. 
3. Select Thinkin’ Science. 
4. Click Add/Remove . . .
5. Follow the on-screen instructions to complete the process.

If any problems are encountered during uninstallation, you may need to manually remove the files from 
your hard drive. This will also erase any files saved from within the program.

To manually uninstall Thinkin’ Science from your system, perform the following steps:
1. Double-click the My Computer icon on the Desktop
2. Double-click the C: drive icon.
3. Double-click the Program Files folder icon.
4. Double-click the Edmark folder icon.
5. Click the Thinkin’ Science folder, highlighting it.
6. Click the File pull-down menu and select Delete.
7. Verify that you have the correct folder highlighted and click Yes. If additional prompts appear 

during this process, click Yes again.
8. Close all windows opened during this process.

Thinkin’ Science has now been completely removed from your system.



Troubleshooting “Illegal Operation” and “Invalid Page fault” Error Messages,
System Lockups and Erratic Program Behavior. 

There are many possible causes for error messages, system lockups, and erratic program behavior. The 
following steps are suggestions for resolving these problems.

Step 1   –   Corrupt Files  
Step 2   –   Temp Files and Drive Integrity  
Step 3   –   Application Conflicts  
Step 4   –   Driver Conflicts  



Step 1 – Corrupt Files

If one of the program files has become corrupt, any number of problems may occur. Removing and then 
reinstalling the program will recreate these files and may resolve the problem. 

To remove and then reinstall a program, follow these steps: 
1. Click Start | Settings  Control Panel.
2. Double-click Add/Remove Programs. 
3. Select Thinkin’ Science.
4. Click the Add/Remove . . . button. 
5. Follow the on-screen instructions.
6. Once the system has restarted, insert the Thinkin’ Science CD. 
7. Install the program as detailed in the Thinkin’ Science User's Guide.
8. Once installation is complete, leave the CD-ROM in the drive and try running the program.

If the problem is not resolved, proceed to step 2  .   



Step 2 – Temp Files and Drive Integrity

Back to step 1   –   Corrupt Files  

If you are still experiencing problems, try deleting any temporary files and running ScanDisk as described 
below.

Deleting Temporary Files

While running, many programs create temporary files on your hard drive, but they do not always remove 
them when complete. Windows tends to act erratically when there is an excessive number of temporary 
files on your hard drive. Removing these excess files may resolve your problem.

To erase temporary files, follow these steps: 
1. Click Start | Shut Down. 
2. Click Restart the computer in MS-DOS mode and then click Yes. 
3. At the C:\> prompt, type: DEL %TEMP%\*.TMP and press Enter 
4. Type: EXIT and press Enter. This returns you to Windows 95. 

Running ScanDisk

Errors on your hard drive can cause erratic behavior and data loss/corruption. ScanDisk will check your 
hard drive for these errors and attempt to repair them. Please refer to Windows Help for further 
information on ScanDisk. 

To run ScanDisk, follow these steps: 
1. Click Start | Programs  Accessories 
 System Tools 
 ScanDisk. 
2. Select all hard drives listed and click Start.
3. When ScanDisk is finished, click Close.
4. Click Start | ShutDown.
5. Select Restart the Computer and then click OK.
6. Once the computer has restarted, run the Edmark program. 

If the problem is not resolved, proceed to step 3  .  



Step 3 – Application Conflicts

Back to step 2   –   Temp Files and Drive Integrity  

If the problem continues, then there may be a conflict with another program running in the background. 
The Windows configuration file called WIN.INI may contain Load= and Run= entries. If present, these 
entries specify programs that are automatically loaded when Windows is started. Sometimes these 
programs interfere with other software on your system. They also use system resources and therefore 
cannot be closed using the Task Manager. You may need to remove one or more of these programs to 
free up system resources or resolve a conflict. 

To disable programs on the Load= and Run= lines, follow these steps: 
1. Click Start | Run.
2. In the Open: field, type: WIN.INI. 
3. Click OK. The WIN.INI file is displayed on the Windows Notepad.
4. From the Notepad, click the File pull-down menu and select Save As.
5. In the File name: field, type: WIN.EDM.
6. Click Save. (You now have a backup copy of your WIN.INI file, named WIN.EDM.)
7. Use your mouse to place the cursor at the beginning of the Load= line. This line is usually found 

near the top of the WIN.INI file.
8. Type a semicolon at the beginning of the Load= line. The line should look like this when you are 

done:
;Load= (current information on the Load= line).

9. Use your mouse to place the cursor at the beginning of the Run= line. This line is usually found 
near the top of the WIN.INI file very close to the Load= line.

10. Type a semicolon at the beginning of the Run= line.* It should look like this when you are done:
;Run= (current information on the Run= line).

11. Click the File pull-down menu and select Save As.
12. In the File name: field, type: WIN.INI.
13. Click Save. 
14. At the prompt asking if you wish to replace the existing file, click Yes.
15. Click the File pull-down menu and select Exit. 
16. Click Start | Shutdown. 
17. Select Restart the Computer and click Yes. (Windows must be restarted for the changes to take 

effect.) 

*Note: If you are using KidDesk Family Edition for Windows 95, “c:\progra~1\kiddes~1\kiddesk.exe” may 
be specified in the Run= line. Changing this line will prevent KidDesk Family Edition from starting 
automatically when you start Windows. Modify only the Load= line if you do not want KidDesk to be 
affected. If you modify the Run= line and want KidDesk Family Edition to start automatically again, enter 
the KidDesk Adult Section. Click the Options pull-down menu and select Startup Options. In the dialog 
box, select Start KidDesk automatically when starting Windows . . . and click OK. 

Removing Icons from the Startup Group

Programs can also be automatically launched from the Startup group. To check the contents of the 



Startup group, click Start | Programs  Startup. Remove icons from this group to see if the problem is a 
conflict with one of these programs. You may want to remove all the icons from this group at first to see if 
the problem is resolved. Then you can try adding the icons back one at a time, restarting the computer 
after each addition, to pinpoint the source of the problem. 

To remove icons from the Startup group, follow these instructions: 
1. Click Start | Settings  Taskbar. 
2. Click the Start Menu Programs tab. 
3. Click the Advanced button. 
4. Double-click the Programs folder icon on the left side of the window. 
5. Click the Startup folder icon. The icons contained in this folder will be displayed in the right pane 
of the Explorer window. 
6. Click and drag the icons from the right pane to your desktop. 
7. Click the File pull-down menu and select Exit. This does not remove the applications from your 
system. It only prevents them from loading automatically when the system starts.
8. Click Start | Shut Down. 
9. Select Restart the Computer. 
10. Click OK. 
11. Once the computer is restarted, run the Edmark program. 

If the problem is not resolved, proceed to step 4  .  



Step 4 – Driver Conflicts

Back to step 3   –   Application Conflicts  

If the problem is still not resolved, then there may be a conflict with a hardware driver running on your 
system. Drivers included with Windows 95 and hardware devices are not always the latest, and updated 
drivers are often available. Contact the manufacturer(s) of your video card, sound card, and CD-ROM 
drive to obtain the latest version of their Windows 95 drivers. 

You should also check to make sure that your existing devices are configured correctly. Use the Windows 
95 Device Manager to do this. 

Follow these instructions to check your devices using the Device Manager: 
1. Click Start | Settings  Control Panel.
2. Double-click the System icon.
3. Click the Device Manager tab. 

You should now see a list of the different devices installed on your system. If any of the items displayed 
has a yellow exclamation point next to it, then that device is not configured correctly. Contact the 
manufacturer of the device for further assistance. 

If these suggestions do not resolve the problem, please contact our Technical Support Department. Click 
here for information on contacting Edmark Technical Support  .   



Error Message – “Changing Video Modes Not Supported”

Thinkin’ Science may adjust the size of the display so that only Thinkin’ Science is visible on the screen 
(this is known as “AutoResize”). If your current video driver does not support this display change, then 
you will receive an error message stating “Changing video modes not supported.”

To resolve this problem, you will need to update your Windows 95 video drivers. These new drivers 
should be available from the manufacturer of your video card, or computer system. Once you have 
installed new drivers, this error message should no longer appear.

An alternative solution for this problem is to stop Thinkin’ Science from changing the display size. To do 
this, you will need to use the Edmark Registry Editor to turn off “AutoResize”. Review the Using the 
Edmark Registry Utility for further instructions.



Error Message – “Resource Manager Error”

A “Resource Manager Error” typically occurs when one of the program resource files is corrupt or is 
incorrectly marked as “read-only.” 

To correct this problem, you should first make sure that you are not launching the program directly from 
the CD-ROM. When Thinkin’ Science is installed, an Edmark group is created in the Start menu. To 
correctly launch Thinkin’ Science, use the icon in this group. If Thinkin’ Science does not launch, then 
there may be an incorrectly marked Thinkin’ Science resource file. Changing the file attributes should 
resolve this problem. 

To change the Thinkin’ Science file attributes, follow these instructions: 
1. Double-click the My Computer icon on the Desktop. 
2. Double-click the C: drive icon. 
3. Double-click the Program Files folder icon. 
4. Double-click the Edmark folder icon. 
5. Double-click the Thinkin’ Science folder icon. 
6. Click the Edit pull-down menu and select Select All. 
7. Click the File pull-down menu and select Properties. 
8. Click the box next to “Read-only” so that it does not contain a check-mark. 
9. Click OK. 
10. Click the File pull-down menu and select Close from all windows opened during this process.
11. Run Thinkin’ Science.

If the error still occurs, then there may be a corrupt resource file. Completely removing the program, 
running a drive integrity check, and then reinstalling the program should correct this problem. 

To completely remove Thinkin’ Science, follow these instructions: 
1. Click Start | Settings  Control Panel. 
2. Double-click Add/Remove Programs. 
3. Select Thinkin’ Science.
4. Click the Add/Remove. . . button. 
5. Follow the on-screen instructions. 
6. After the system has restarted, double-click the My Computer icon on the Desktop. 
7. Double-click the C: drive icon. 
8. Double-click the Program Files folder icon. 
9. Double-click the Edmark folder icon. 
10. Click the folder titled Thinkin’ Science, highlighting it. If this folder does not exist, then proceed 

to Step 13. 
11. Click the File pull-down menu and select Delete. 
12. Verify that you have the correct folder highlighted and then click Yes to all prompts. 
13. Click the File pull-down menu and select Close for all windows opened during this process. 
14. Click Start | Programs  Accessories 
 System Tools 
 Scandisk.

The Scandisk program checks the integrity of the hard drive and ensures that no further file corruption 
exists. Please refer to Windows Help for further information on Scandisk.



15. Select all hard drives and click Start.
16. Once ScanDisk is complete, click Close.
17. Reinstall the Thinkin’ Science program as explained in the product's User's Guide. 

You should no longer receive the “Resource Manager Error” message.



Improving performance by removing background applications

The Windows configuration file called WIN.INI may contain Load= and Run= entries. If present, these 
entries specify programs that are automatically loaded when Windows is started. Sometimes these 
programs can slow system performance. They also use system resources and can interfere with other 
software on your system. You may need to remove one or more of these programs to free up system 
resources, improve program performance, or resolve a conflict. 

To disable programs on the Load= and Run= lines, follow these steps: 
1. Click Start | Run.
2. In the Open: field, type: WIN.INI. 
3. Click OK. The WIN.INI file is displayed on the Windows Notepad.
4. From the Notepad, click the File pull-down menu and select Save As.
5. In the File name: field, type: WIN.EDM.
6. Click Save. (You now have a backup copy of your WIN.INI file, named WIN.EDM.)
7. Use your mouse to place the cursor at the beginning of the Load= line. This line is usually found 

near the top of the WIN.INI file.
8. Type a semicolon at the beginning of the Load= line. The line should look like this when you are 

done:
;Load= (current information on the Load= line)

9. Use your mouse to place the cursor at the beginning of the Run= line. This line is usually found 
near the top of the WIN.INI file very close to the Load= line.

10. Type a semicolon at the beginning of the Run= line.* It should look like this when you are done:
;Run= (current information on the Run= line)

11. Click the File pull-down menu and select Save As.
12. In the File name: field, type: WIN.INI.
13. Click Save. 
14. At the prompt asking if you wish to replace the existing file, click Yes.
15. Click the File pull-down menu and select Exit. 
16. Click Start | Shutdown. 
17. Select Restart the Computer and click Yes. (Windows must be restarted for the changes to take 

affect.) 

*Note: If you are using KidDesk Family Edition for Windows 95, “c:\progra~1\kiddes~1\kiddesk.exe” may 
be specified in the Run= line. Changing this line will prevent KidDesk Family Edition from starting 
automatically when you start Windows. Modify only the Load= line if you do not want KidDesk to be 
affected. If you modify the Run= line and want KidDesk Family Edition to start automatically again, enter 
the KidDesk Adult Section. Click the Options pull-down menu and select Startup Options. In the dialog 
box, select Start KidDesk automatically when starting Windows . . . and click OK. 

Removing Icons from the Startup Group;

Programs can also be automatically launched from the Startup group. To check the contents of the 
Startup group, click Start | Programs  Startup. Remove icons from this group to see if the problem is a 
conflict with one of these programs. You may want to remove all the icons from this group at first to see if 
the problem is resolved. Then you can try adding the icons back one at a time, restarting the computer 



after each addition, to pinpoint the source of the problem. 

To remove icons from the Startup group, follow these instructions: 
1. Click Start | Settings  Taskbar. 
2. Click the Start Menu Programs tab. 
3. Click the Advanced button. 
4. Double-click the Programs folder icon on the left side of the window. 
5. Click the Startup folder icon. The icons contained in this folder will be displayed in the right pane 
of the Explorer window. 
6. Click and drag the icons from the right pane to your desktop. 
7. Click the File pull-down menu and select Exit. This does not remove the applications from your 
system. It only prevents them from loading automatically when the system starts.
8. Click Start | Shut Down. 
9. Select Restart the Computer. 
10. Click OK. 
11. Once the computer is restarted, run the Edmark program. 



Improving performance by installing the latest hardware drivers.

Windows uses device drivers to communicate with each hardware device installed on your system. The 
device drivers that come with the hardware device or with Windows 95 are not always the most recent 
versions. Installing newer device drivers often improves the performance of these hardware devices 
and/or resolves system conflicts. We suggest contacting the manufacturer of your video card, sound card,
and CD-ROM drive to see if updates are available.



System Requirements

Windows®
Windows 3.1x, Windows 95 or later
486 (33MHz or greater recommended), Pentium or better.
Hard drive with 5 MB free
8MB memory (RAM)
Super VGA graphics, 640x480, 256 or more colors
Double-speed (2X) or faster CD-ROM drive
Windows-compatible sound card

Optional
Windows-compatible printer
Edmark TouchWindow



Contacting Edmark Technical Support

Before contacting Technical Support, please have the following information ready: 

The version of Windows you are running and your available system resources. (Double-click the 
My Computer icon on the Desktop. Click the Help pull-down menu and select About.)

The version of Thinkin’ Science you are using. (Run Thinkin’ Science. Open the Adult Options 
and click Credits. The version number is displayed this screen.)

Your system specifications (for example, "486DX/66, 8 megabytes of RAM, 1.2GB hard drive") 
Printer and sound card type, if any (for example, "HP 550C" printer, "SoundBlaster 16" sound 

card) 
The exact text of any error message(s) you are receiving as they appear on your screen. 

When writing us, please include a detailed description of the problem you are encountering. Text copies 
or printouts of the following are helpful:

Your C:\AUTOEXEC.BAT file
Your C:\CONFIG.SYS file 
The first page of your C:\Windows\WIN.INI file
The first two pages of your C:\Windows\SYSTEM.INI file 

Frequently Asked Questions

Answers to frequently asked questions are available in the Technical Support area of the Edmark 
Web site. Visit:
http://www.edmark.com.

Automated support is available 24 hours a day, 7 days a week via our automated support system.
To access this system, dial (425) 556-3680. FAX responses may also be requested via this 
system. 

To receive a catalog of documents available via e-mail, send a message to: 
solutions@edmark.com. In the subject or body of the message, type: catalog. (All other text will
be ignored.)

Telephone

Call us at (425) 556-8480, during the following hours (Pacific Time):

8 a.m. to 6 p.m. - Monday through Friday (Holiday hours may vary.)
Please have your computer turned on and ready to use when you call us. 

FAX

FAX us at (425) 556-8940; 24 hours a day, 7 days a week. Specify "Technical Support" in the 
header.

Automated FAX responses may also be requested via our automated support system. Dial (425) 
556-3680 (This is a voice line.)

Online Form

Use our online form to send your questions to our technical support staff. Visit:
http://www.edmark.com/ts/pctech/pctechform.html



Electronic Mail

You can contact an Edmark PC technician at the following e-mail address:
pctech@edmark.com

US Mail

You can also send us mail to the following address:
Edmark Corporation
Attention: Technical Support
Building C
P.O. Box 97021
Redmond, WA 98073-9721




